Задать вопрос
27 августа, 20:48

Нужно в паскале написать программу с одномерным массивом из десяти элементов, чтоб она находила количество чётных, нечётных и среднее арифметическое. Это всё в одной программе.

+3
Ответы (1)
  1. 27 августа, 23:42
    0
    var a:array [1 ... 10] of integer;

    i, k1, k2, s1, s2:integer;

    begin

    for i: = 1 to 10 do

    a[i]: = Random (100) ;

    writeln (a) ;

    for i:=1 to 10 do

    begin

    if a[i] mod 2 = 0 then

    begin

    k1:=k1+1;

    s1:=s1+a[i]

    end

    else

    begin

    k2:=k2+1;

    s2:=s2+a[i]

    end

    end;

    writeln ('Количество чётных элементов: ', k1) ;

    writeln ('Количество не чётных элементов: ', k2) ;

    writeln ('Cреднее арифметическое чётных элементов: ', s1/k1) ;

    writeln ('Cреднее арифметическое не чётных элементов: ', s2/k2) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Нужно в паскале написать программу с одномерным массивом из десяти элементов, чтоб она находила количество чётных, нечётных и среднее ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы