Задать вопрос
15 июня, 21:45

Вася купил себе новую квартиру и теперь занимается переездом. У него есть N книг, Вася хочет перевозить их отдельно от основных вещей. Для транспортировки он может использовать коробки, которые вмещают M книг каждая. Помогите Васе, какое кол-во коробок ему понадобится для перевозки всех книг за один раз. Составить программу на Паскале или другом ЯП

+5
Ответы (1)
  1. 16 июня, 01:09
    0
    a - количество коробок

    program one;

    var N, M, a : integer;

    begin

    read (N, M) ;

    if N mod M > 0 then

    begin

    a : = (N div M) + 1;

    end;

    if N mod M = 0 then

    begin

    a : = N div M;

    end;

    write (a) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Вася купил себе новую квартиру и теперь занимается переездом. У него есть N книг, Вася хочет перевозить их отдельно от основных вещей. Для ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы