Задать вопрос
22 июля, 21:15

Написать программу в Pascal по 2 способам for и while.

Задание: Вывести на экран числа оканчивающаяся на 3 в промежутке от n до 150

+2
Ответы (1)
  1. 22 июля, 22:11
    0
    While:

    var

    n: integer;

    begin

    write ('Введите начало диапазона (n) : ') ;

    readln (n) ;

    while n < 150 do

    begin

    if n mod 10 = 3

    then write (n, ' ') ;

    n : = n + 1; end;

    end.

    for:

    var

    n, i: integer;

    begin

    write ('Введите начало диапазона (n) : ') ;

    readln (n) ;

    for i : = n to 150 do

    if n mod 10 = 3

    then write (i, ' ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу в Pascal по 2 способам for и while. Задание: Вывести на экран числа оканчивающаяся на 3 в промежутке от n до 150 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы