Задать вопрос
5 ноября, 06:37

Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего дня. Определить какой суммарный путь он пробежал за первые 7 дней тренировок.

Написать программу в Pascal

+3
Ответы (1)
  1. 5 ноября, 07:50
    0
    Program lyg;

    var

    all, last, seven: real;

    ii, day: integer;

    begin

    last : = 10;

    all : = 10;

    day : = 0;

    for ii : = 1 to 10 do

    begin

    last : = last + (last*0.1) ;

    all : = all+last;

    if ii=7 then

    seven : = all;

    writeln ('day ', ii,': ', round (last)) ;

    if day = 0 then

    if all > 100 then

    day : = ii;

    end;

    writeln ('Overall distance of 7 days: ', seven) ;

    writeln ('Distance 100km is reached at ', day,' day') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего дня. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы