Задать вопрос
26 декабря, 06:11

Написать программу, находящую скорость или время или пройденное расстояние в зависимости от запроса пользователя. (авс паскаль)

+3
Ответы (1)
  1. 26 декабря, 07:49
    0
    Program fgg;

    var

    x: String[10];

    t, v, s: Real;

    begin

    Write ('Что будем искать?: ') ;

    ReadLn (x) ;

    if x = 'скорость' then

    begin

    Write ('Введите расстояние: ') ;

    ReadLn (s) ;

    Write ('Введите время: ') ;

    ReadLn (t) ;

    WriteLn ('Скорость=', s / t) ;

    end

    else if x = 'время' then

    begin

    Write ('Введите расстояние: ') ;

    ReadLn (s) ;

    Write ('Введите скорость: ') ;

    ReadLn (v) ;

    WriteLn ('Время=', s / v) ;

    end

    else if x = 'расстояние' then

    begin

    Write ('Введите скорость: ') ;

    ReadLn (v) ;

    Write ('Введите время: ') ;

    ReadLn (t) ;

    WriteLn ('Расстояние=', v * t) ;

    end

    else

    WriteLn ('Неверно указано, что будем искать.') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, находящую скорость или время или пройденное расстояние в зависимости от запроса пользователя. (авс паскаль) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы