Задать вопрос
7 ноября, 14:17

Написание разветвляющихся программ на языке Pascal.

Задание №1:Если а>b и b>c тогда а = max+3.

Задание №2:Вывести на экран среднее арифметическое максимального и минимального из 3 чисел.

+3
Ответы (1)
  1. 7 ноября, 15:19
    0
    1) Var a, b, c, max: Integer;

    Begin

    writeln ('Введите a, b, c, max') ;

    readln (a, b, c, max) ;

    if (a>b) and (a>c) then a:=max+3;

    writeln (a) ;

    End.

    2) Var a, b, c, max, min: Integer;

    Begin

    writeln ('Введите 1,2,3 число') ;

    readln (a, b, c) ;

    max:=a;

    if max
    if max
    min:=a;

    if min>b then min:=b;

    if min>c then min:=c;

    writeln ('Среднее: ', (max+min) / 2) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написание разветвляющихся программ на языке Pascal. Задание №1:Если а>b и b>c тогда а = max+3. Задание №2:Вывести на экран среднее ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Где ошибка? Sub сер Dim x, y, z, f, max, min As Single x = Val (InputBox (2)) y = (InputBox (6)) z = (InputBox (10)) If x / 2 > y / 3 > z / 4 Then If x / 2 > y / 3 Then max = x / 2 Else max = y / 3 End If End If Else If y / 3 > z / 4 Then max =
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Паскаль Как написать программу, которая уменьшала бы ВСЕ максимальные элементы в два раза? Так? max:=a[1,1]; if a[i, j] > max then max: = a[i, j]; end; max: = max div 2;
Ответы (2)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
найдите среднее арифмитическое минимального и максимального элемента из 10 вводимых. что не так? Program Ex1; var i, max, min, x,:integer; Sr:real; begin for i : = 1 to 10 do begin writeln ('вв-те ', i,' число') ; readln (x) ; End;
Ответы (1)