Задать вопрос
10 июня, 04:17

Составьте программу на паскале для упорядочения пяти чисел по убыванию и нахождение их суммы

+1
Ответы (1)
  1. 10 июня, 07:59
    0
    Var

    A: array [1 ... 5] of real;

    i, j: byte;

    sum, tmp: real;

    begin

    sum : = 0;

    { Заполнение массива }

    for i : = 1 to 5 do

    begin

    write ('A[', i, '] = ') ;

    readln (A[i]) ;

    sum : = sum + A[i]; / / подсчет суммы

    end;

    writeln (#13 + 'Сумма элементов = ', sum) ;

    { Сортировка по убыванию }

    for i : = 1 to 4 do

    for j : = i + 1 to 5 do

    if A[i] < A[j] then

    begin

    tmp : = A[i];

    A[i] : = A[j];

    A[j] : = tmp;

    end;

    { Вывод }

    writeln ('Отсортированный массив: ') ;

    for i : = 1 to 5 do

    write (' ', A[i]) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу на паскале для упорядочения пяти чисел по убыванию и нахождение их суммы ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы