Задать вопрос
2 января, 15:04

Показать, что любую сумму, большую 7 копеек, можно выплатить, используя только 3-х и 5-ти копеечные монеты. (То есть, для любого целого N>7 найти такие целые числа x и y, что 3x+5y=N). Написать программу в Pascal

+3
Ответы (1)
  1. 2 января, 16:24
    0
    program Diofant;

    var

    n, x, y: integer;

    begin

    n : = 125;

    {3x + 5y = n, n > = 0, x > = 0, y > = 0;

    n - 5y > = 0, y < = n / 5}

    for y : = 0 to n div 5 do

    begin

    if (n - 5 * y) mod 3 = 0 then

    begin

    x : = (n - 5 * y) div 3;

    Writeln ('3 * ', x, ' + 5 * ', y, ' = ', n)

    end;

    end;

    Readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Показать, что любую сумму, большую 7 копеек, можно выплатить, используя только 3-х и 5-ти копеечные монеты. (То есть, для любого целого N>7 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы