Задать вопрос
29 марта, 14:37

3. Чему будет равно значение целой переменной a после выполнения этого фрагмента программы?

a:=2;

for i:=0 to 2 do begin

a:=a+i;

end;

Ответ:

введите число

4. Чему будет равно значение целой переменной a после выполнения этого фрагмента программы?

a:=4;

for i:=1 to 4 do begin

a:=a+a;

end;

Ответ:

введите число

5. Какое число будет выведено на экран после выполнения этого фрагмента программы?

for i:=3 downto 2 do

write (i) ;

Ответ:

введите число

6. Какое число будет выведено на экран после выполнения этого фрагмента программы?

write (4) ;

for i:=3 downto 2 do

write (2*i) ;

Ответ:

введите число

7. Какое число будет выведено на экран после выполнения этого фрагмента программы?

write (1) ;

for i:=2 to 1 do

write (i) ;

+5
Ответы (2)
  1. 29 марта, 15:17
    0
    3. а = 5

    4. а=64

    5. вывдет 32 (получается 32, потому что нету пробелов между 3 и 2)

    6. 464 (потому что между 6 и 4 нету пробелов)

    7. i = 1
  2. 29 марта, 15:29
    0
    Цикл проработает 2 раза, следовательно значение переменной a = 10 - 2 = 8
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «3. Чему будет равно значение целой переменной a после выполнения этого фрагмента программы? a:=2; for i:=0 to 2 do begin a:=a+i; end; ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
1) Найдите ошибки в программе и запишите правильный вариант Var a, b, i, x:real; Begin Read (x) ; a:=x; For i:=1 downto b do Begin i:=i+3; a: = a/2; x:=x+a; End; write (x) ; End.
Ответы (1)
Цикл с параметром и шагом - 1 объявляется с использованием конструкции a) for i:=i1 downto i2 do begin ... end; b) repeat begin ... end until (выражение_условие) ; c) for i:=i1 to i2 do begin ... end; d) if (выражение_условие) begin ...
Ответы (1)
6) Определите, что будет напечатано в результате работы следующего фрагмента программы: var n, s: integer; begin s : = 0; for n:=4 to 13 do begin s : = s + 15; end; write (s) end.
Ответы (1)
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X) ; 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
Сколько раз выполнится тело цикла? 1) For x:=3 to 8 do write ('*') ; 2) For x:=1 to 1 do write ('*') ; 3) For x:=5 to 3 do write ('*') ; 4) For x:=7 downto 4 do write ('*') ; 5) For x:=2 downto 2 do write ('*') ; 6) For x:=4 downto 9 do write ('*') ;
Ответы (1)