Задать вопрос
25 августа, 09:39

У студента-филолога Васи есть замечательный друг Петя. И Петя никак не может выучить английский язык. Английский текст Петя еще кое-как читает, но пишет с ужасными ошибками, причем чаще всего он вставляет в слова лишние буквы.

Вася решил помочь Пете. Теперь каждый день Вася диктует Пете слова, а Петя их записывает. После семестра занятий Петя стал писать много лучше и теперь делает в словах только по одной ошибке. Чтобы автоматизировать процесс исправления ошибок, Вася просит Вас написать программу, которая удаляет из слова одну лишнюю букву и показывает Пете правильное слово.

Испраьте ошибки или напишите свой код сколько пытался ничего не получается:

Вот мой код

var s:string;

t:integer;

begin

readln (t) ;

readln (S) ;

Delete (S, t, 1) ;

writeln (s) ;

end.

+5
Ответы (1)
  1. 25 августа, 13:24
    0
    Составлено на джаве:

    import java. util. Scanner;

    public class mistake {

    public static void main (String[] args) {

    Scanner in = new Scanner (System. in) ;

    System. out. print ("Введите слово с ошибкой: ") ;

    String word = in. nextLine () ;

    System. out. print ("Введите ошибку: ") ;

    String mistake = in. nextInt () ;

    StringBuffer sb = word;

    sb. delete (mistake) ;

    System. out. println ("Слово без ошибки"+sb) ;

    }

    }
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «У студента-филолога Васи есть замечательный друг Петя. И Петя никак не может выучить английский язык. Английский текст Петя еще кое-как ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы