Задать вопрос
10 декабря, 10:18

Решите в Pascal ABC

На вход программе подаются 4 целых числа, по модулю не превосходящие 10^6: m, n, k, l. Если остаток от деления m на n равен k или l, то выведите 1, в противном случае - любое другое число.

Условный оператор использовать нельзя!

+5
Ответы (1)
  1. 10 декабря, 12:20
    0
    var m, n, k, l : longint;

    begin

    readln (m, n, k, l) ;

    writeln (((m mod n) xor k) * ((m mod n) xor l) + 1) ;

    end.

    Работает программа следующим образом:

    Если провести операцию XOR с двумя равными числами, то ответом будет 0.

    Если остаток от деления равен k или l, то одна из скобок равна 0, что при умножении даст 0. Для выполнения условия задачи добавим 1.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Решите в Pascal ABC На вход программе подаются 4 целых числа, по модулю не превосходящие 10^6: m, n, k, l. Если остаток от деления m на n ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы