Задать вопрос
5 мая, 18:50

Помогите написать на Паскале

Дано N пицц Пиццу резать нельзя! Если распределить пиццы поровну среди М друзей, то по скольку пицц получит каждый друг и сколько пицц окажутся не распределенными? Программа получает на вход два натуральных числа N и M, при чем N > M. N не превосходит 10 9 Программа должна вывести два числа - сколько пицц достанется каждому другу и сколько пицц останется не распределенными через пробел

+2
Ответы (1)
  1. 5 мая, 19:32
    0
    До нельзя просто. div находит целое число от деления, mod - остаток. Путём деления и находим, кто сколько пицц скушает =)

    program Pizza2friends;

    var N, M:integer;

    begin

    writeln ('Введите количество пицц') ;

    read (N) ;

    writeln ('Введите количество друзей') ;

    read (M) ;

    if N > M then

    writeln ('У каждого друга будет ', N div M,' пицц. Останется ', N mod M,' ничьих пицц.')

    else writeln ('Пицц должно быть больше, чем друзей') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать на Паскале Дано N пицц Пиццу резать нельзя! Если распределить пиццы поровну среди М друзей, то по скольку пицц получит ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы