Задать вопрос
29 января, 15:20

Составьте программу проверяющую верно ли утверждение что произведение цифр введенного вами трехзначного целого числа не делится на сумму 1 и 3 цифр и делится на 3.

+1
Ответы (2)
  1. 29 января, 15:59
    0
    Ну как - то так, если я верно понял условие

    C++

    #include

    using namespace std;

    string s;

    main () {

    cin >>s;

    int a[4];

    a[1] = s[0] - '0';

    a[2] = s[1] - '0';

    a[3] = s[2] - '0';

    if (a[1] * a[2] * a[3] % (a[1] + a[2] + a[3]) ! = 0 && a[1] * a[2] * a[3] % 3 = = 0) cout <<"YES";

    else

    cout <<"NO";

    }
  2. 29 января, 18:16
    0
    begin

    var n : = ReadInteger () ;

    var p : = (n div 100) * (n div 10 mod 10) * (n mod 10) ;

    Write ('произведение цифр числа ', n,

    ' не делится на сумму 1 и 3 цифр'+

    ' и делится на 3: ') ;

    Write ((p mod (n div 100 + n mod 10) 0) and (p mod 3 = 0))

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу проверяющую верно ли утверждение что произведение цифр введенного вами трехзначного целого числа не делится на сумму 1 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы