Задать вопрос
1 декабря, 22:06

1) Написать программу, которая вычисляет сумму первых n целых положительных чисел. Количество суммируемых чисел должно вводиться во время работы программы. (Использовать цикл While)

+5
Ответы (2)
  1. 1 декабря, 23:09
    0
    Var

    n, a, sum, i: longint;

    begin

    readln (n) ;

    sum : = 0;

    i : = 1;

    while (i < = n) do beign

    read (a) ;

    sum : = sum + a;

    inc (i) ;

    end;

    writeln (sum) ;

    end.
  2. 2 декабря, 01:55
    0
    Var i, s, n:Integer;

    begin

    ReadLn (n) ;

    while i
    begin

    i:=i+1;

    s:=s+i

    end;

    WriteLn (s)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1) Написать программу, которая вычисляет сумму первых n целых положительных чисел. Количество суммируемых чисел должно вводиться во время ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы