Задать вопрос
7 февраля, 16:20

В массиве, состоящем из 10 случайных чисел в интервале[-20; 10], определите количество и сумму элементов кратных 3. Pascal ABC. 9 класс

+3
Ответы (2)
  1. 7 февраля, 16:33
    0
    Var a:array [1 ... 10] of integer;

    i, k, s:integer;

    begin

    for i: = 1 to 10 do

    a[i]: = Random (31) - 20;

    writeln (a) ;

    for i:=1 to 10 do

    if (a[i] 0) and (a[i] mod 3 = 0) then

    begin

    s:=s+a[i];

    k:=k+1

    end;

    writeln ('Количество элементов кратных 3 равно ', k,' и их сумма равна ', s)

    end.

    Ноль исключён из подсчёта элементов.
  2. 7 февраля, 18:17
    0
    Var a: array[0 ... 10] of Integer;

    i, sum, count: Integer;

    begin

    sum:=0;

    count:=0;

    for i:=0 to 9 do

    begin

    a[i]:=random (31) - 10;

    writeln ('Число ', i+1,': ', a[i]) ;

    end;

    for i:=0 to 9 do

    begin

    if a[i] mod 3=0 then

    begin

    count:=count+1;

    sum:=sum+a[i];

    end;

    end;

    writeln ('Сумма чисел: ', sum) ;

    writeln ('Кол-во: ', count) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «В массиве, состоящем из 10 случайных чисел в интервале[-20; 10], определите количество и сумму элементов кратных 3. Pascal ABC. 9 класс ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы