Задать вопрос
18 июля, 09:19

Информатика: решение задачи на языке Паскаль. Текст задачи: даны три натуральных числа. Напишите программу, определяющую существует ли треугольник с такими длинами сторон. Если такой треугольник существует, то определите его тип (равносторонний, равнобедренный, разносторонний)

+3
Ответы (1)
  1. 18 июля, 12:20
    0
    Var

    i, a, b, c: integer;

    function check_is (a, b, c: integer) :

    boolean;

    begin

    if a > = b + c then check_is : = false

    else if b > = a + c then

    check_is : = false else

    if c > = a + b then check_is : = false else

    check_is : = true;

    end;

    procedure check_how (a, b, c: integer) ; begin

    if ((a = b) and (b = c) and (a = c)) then writeln ('равносторонний') else

    if ((a = b) or (b = c) or (a = c)) then writeln ('равнобедренный') else writeln ('разносторонний') ;

    end;

    begin

    writeln ('Введите стороны треугольника') ;

    read (a, b, c) ;

    if check_is (a, b, c) then check_how (a, b, c) else writeln ('Нет такого треугольника!') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Информатика: решение задачи на языке Паскаль. Текст задачи: даны три натуральных числа. Напишите программу, определяющую существует ли ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы