Задать вопрос
15 декабря, 09:24

3. Даны два целых числа. Если они оба четны, то большее из них поделить на 2; если оба нечетны, то каждое умножить на 2; в противном случае нечетное из чисел увеличить на 1.

4. Составить программу поиска двузначных чисел таких, что если к сумме цифр этого числа прибавить квадрат этой суммы, то получится это число.

5. Пусть A и B - положительные вещественные числа, большие 1, причем A>B. Составить программу для поиска такого наименьшего натурального m, что Bm> m*A.

Нужна запись на языке СИ

+2
Ответы (1)
  1. 15 декабря, 09:33
    0
    Тут два задания на С. В 3 я не понял что требуется.

    #include

    void mission3 (n1, n2) {

    int one = n1;

    int two = n2;

    / / нечетные

    if (one % 2 = = 1 && two % 2 = = 1) {

    printf ("One: %d/n", one * 2) ;

    printf ("Two: %d/n", two * 2) ;

    / / четные

    } else if (one % 2 = = 0 && two % 2 = = 0) {

    / / определяем какое больше

    if (one > two) {

    printf ("One: %d/n", one / 2) ;

    } else {

    printf ("Two: %d/n", two / 2) ;

    }

    / / разные

    } else {

    / / определяем какое нечетное

    if (one % 2 = = 1) {

    printf ("One: %d/n", one + 1) ;

    } else {

    printf ("Two: %d/n", two + 1) ;

    }

    }

    }

    void mission4 () {

    / / перебираем все двухзначные числа

    for (int i = 10; i < 99; i++) {

    int n1 = i % 10; / / получаем остаток от деления

    int n2 = i / 10; / / получаем целую часть

    / / если к сумме цифр этого числа прибавить квадрат этой суммы, то получится это число

    if (n1 + n2 + ((n1 + n2) * (n1 + n2)) = = i) {

    printf ("%d/n", i) ;

    }

    }

    }

    int main ()

    {

    / / проверка 3 задания

    mission3 (3, 3) ;

    mission3 (4, 4) ;

    mission3 (4, 5) ;

    / / проверка 4 задания

    mission4 () ;

    return 0;

    }
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «3. Даны два целых числа. Если они оба четны, то большее из них поделить на 2; если оба нечетны, то каждое умножить на 2; в противном случае ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы