Задать вопрос
15 ноября, 01:54

Дана последовательность чисел оканчивающихся на 0 найти сумму и произведение этих чисел (Нужно написать программу в Паскале

+1
Ответы (1)
  1. 15 ноября, 04:15
    0
    Var a, s, p:integer;

    begin

    s:=0;

    p:=1;

    write ('Введите число: ') ;

    readln (a) ;

    while a0 do

    begin

    s:=s+a;

    p:=p*a;

    write ('Введите число: ') ;

    readln (a)

    end;

    writeln ('Сумма чисел в последовательности: ', s) ;

    writeln ('Произведение чисел в последовательности: ', p)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дана последовательность чисел оканчивающихся на 0 найти сумму и произведение этих чисел (Нужно написать программу в Паскале ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы