Задать вопрос
21 сентября, 13:22

С++

Напишите программу, которая заменяет во всей строке одну последовательность символов на другую.

Пример:

Введите строку:

(X > 0) and (Y Y) and (Z 5)

Что меняем: and

Чем заменить: &

Результат

(X > 0) & (Y Y) & (Z 5)

+5
Ответы (1)
  1. 21 сентября, 14:16
    0
    Красивый ввод/вывод сам добавишь

    //Microsoft (R) C/C + + Optimizing Compiler Version 19.00.23506 for x64

    #include

    #include

    using namespace std;

    int main ()

    {

    string str, from, to;

    getline (cin, str) ;

    cin >> from >> to;

    size_t i = 0;

    for (; (i = str. find (from, i)) ! = string::npos; i + = to. length ())

    str. replace (i, from. length (), to) ;

    cout << str;

    }
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «С++ Напишите программу, которая заменяет во всей строке одну последовательность символов на другую. Пример: Введите строку: (X > 0) and (Y ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы