Задать вопрос
10 октября, 16:09

Написать программу на Паскале: Дана S круга. Найти его диаметр D и длину L окружности, ограничивающей этот круг, учитывая, что L = π*D, S = π*D2 (в квадрате) / 4

+3
Ответы (1)
  1. 10 октября, 18:24
    0
    const

    pi = 3.14;

    var

    S, D, L: real;

    begin

    write ('Введите площадь круга: S = ') ;

    readln (S) ;

    D : = 2 * sqrt (S / pi) ; { < - - Вычисляем диаметр круга }

    L : = pi * D; { < - - Вычисляем длину окружности }

    writeln ('Результат:') ;

    writeln (' D = ', D:0:2) ; { < - - Выводим диаметр на экран }

    writeln (' L = ', L:0:2) ; { < - - Выводим длину на экран }

    readln

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу на Паскале: Дана S круга. Найти его диаметр D и длину L окружности, ограничивающей этот круг, учитывая, что L = π*D, S = ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы