Задать вопрос
15 ноября, 20:43

Помогите! Нужно написать программу в С++. Которая ищет первый столбец прямоугольной матрицы без отрицательных элементов.

+4
Ответы (1)
  1. 15 ноября, 21:10
    0
    Выведем номер первого столбца матрицы a[n][m], не содержащего отрицательных элементов, или - 1, если такого столбца не существует.

    Код

    #include

    using namespace std;

    int main () {

    int n, m;

    cin >> n >> m;

    int a[n][m];

    for (int i = 0; i < n; + + i)

    for (int j = 0; j < m; + + j)

    cin >> a[i][j];

    for (int j = 0; j < m; + + j) {

    bool b = 1;

    for (int i = 0; i < n && b; + + i)

    b = (a[i][j] > = 0) ;

    if (b) {

    cout << (j+1) << endl;

    return 0;

    }

    }

    cout << - 1 << endl;

    return 0;

    }
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите! Нужно написать программу в С++. Которая ищет первый столбец прямоугольной матрицы без отрицательных элементов. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы