Задать вопрос
15 августа, 06:40

Составьте программу, которая последовательно запросит 10 целых чисел и в результате сообщит, сколько среди введенных чисел четных и сколько нечетных чисел.

+3
Ответы (1)
  1. 15 августа, 08:08
    0
    Var q, w, e, r, t, y, u, i, o, p, l, s, a: Integer;

    begin

    writeln ('Введите 10 целых чисел') ;

    readln (q, w, e, r, t, y, u, i, o, p) ;

    s:=0;

    a:=0;

    for l:=0 to 9 do

    begin

    if l=0 then if q mod 2=0 then s:=s+1 else a:=a+1;

    if l=1 then if w mod 2=0 then s:=s+1 else a:=a+1;

    if l=2 then if e mod 2=0 then s:=s+1 else a:=a+1;

    if l=3 then if r mod 2=0 then s:=s+1 else a:=a+1;

    if l=4 then if t mod 2=0 then s:=s+1 else a:=a+1;

    if l=5 then if y mod 2=0 then s:=s+1 else a:=a+1;

    if l=6 then if u mod 2=0 then s:=s+1 else a:=a+1;

    if l=7 then if i mod 2=0 then s:=s+1 else a:=a+1;

    if l=8 then if o mod 2=0 then s:=s+1 else a:=a+1;

    if l=9 then if p mod 2=0 then s:=s+1 else a:=a+1;

    end;

    writeln ('Чётных: ', s) ;

    writeln ('Нечётных: ', a) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу, которая последовательно запросит 10 целых чисел и в результате сообщит, сколько среди введенных чисел четных и сколько ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы