Задать вопрос
30 марта, 04:47

Pascal. ABC составьте программу!

На Марс отправляется туристический космолет, который может иметь на борту не более 750 пассажиров. Туристы прибывают группами, количество человек в которых различно. Составьте программу, регулирующую наполняемость космолета, а также вычисляющую необходимое количество гидов (по одному на группу).

+1
Ответы (1)
  1. 30 марта, 06:59
    0
    Program p1;

    uses crt;

    var a, g, i, s, s2:integer;

    begin

    I:=1;

    s:=0;

    while i0 do begin

    read (a) ;

    s:=s+a;

    If s>=750 then begin

    i:=0;

    end;

    If s<=750 then begin

    g:=g+1;

    end;

    end;

    If s>750 then begin

    s2:=s-750;

    writeln (' Не осталось мест для ', s2) ;

    end;

    If s>750 then begin

    s2:=s-a;

    writeln ('Всего попало на космолёт : ', s2) ;

    end;

    749

    writeln ('Понадобилось гидов : ', g) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Pascal. ABC составьте программу! На Марс отправляется туристический космолет, который может иметь на борту не более 750 пассажиров. Туристы ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы