Задать вопрос
26 января, 16:04

Составить программу которая определяет наличие одинаковых цифр в произвольном 3-значном числе

+2
Ответы (1)
  1. 26 января, 18:09
    0
    Var a, a1, a2, a3:integer;

    begin

    readln (a) ;

    a1:=a div 100;

    a2:=a div 10 mod 10;

    a3:=a mod 10;

    if (a1=a2) or (a1=a3) or (a2=a3)

    then writeln ('Одинаковые цифры есть')

    else writeln ('Одинаковых цифр нет') ;

    end.

    Пример:

    121

    Одинаковые цифры есть
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу которая определяет наличие одинаковых цифр в произвольном 3-значном числе ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы