Задать вопрос
4 января, 09:35

Напишите программу вычисления площади и гипотенузы прямоугольного треугольника, если известны его катеты. Но программа должна быть с комментариями посторочно

+5
Ответы (1)
  1. 4 января, 11:53
    +1
    Var {раздел описания переменных}

    a, b: Real; {описание переменных. Переменные а и b вещественного типа}

    begin {раздел или блок непосредственно кода программы}

    WriteLn ('введите катеты') ; {запрос ввода сторон треугольника}

    ReadLn (a, b) ; {ввод сторон треугольника пользователем}

    Writeln ('Площадь треугольника = ', a*b/2) ; {вывод результата нахождения площади треугольника. Площадь равна половине произведения катетов}

    WriteLn ('Гипотенуза=', sqrt (sqr (a) + sqr (b))) ; {вывод результата нахождения гипотенузы. Квадрат гипотенузы равен сумме квадратов катетов, соответственно гипотенуза равна корню квадратному из суммы квадратов катетов. sqr - возведение в квадрат, sqrt - корень из числа.}

    end. {Конец кода программы}
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу вычисления площади и гипотенузы прямоугольного треугольника, если известны его катеты. Но программа должна быть с ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы