Задать вопрос
20 августа, 02:42

Даны натуральные числа n и k. Определить k-ю слева цифру числа n

Язык - СИ

+3
Ответы (1)
  1. 20 августа, 03:29
    0
    Не используя оператора if, присвоить переменной k значение 0, если из введенных чисел x, y, z только одно число является положительным, и значение 1 - в противном случае.

    k = ! (((x>0) && (y<0) && (z<0)) || ((x0) && (z<0)) || ((x<0) && (y0))) ;

    Добавлено через 10 минут 0 секунд

    3) По введенному символу установить, в каких позициях его двоичного кода записаны нули.

    unsigned int i; / / счетчик

    char c; / / введенный символ

    for (i=7; i>=0; i--)

    if (! (c & 1<
    printf ("in %d position stand 0 / n", i) ;
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Даны натуральные числа n и k. Определить k-ю слева цифру числа n Язык - СИ ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Написать программу по "Из трехзначного числа Х вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа Х, то получилось число 237. Найти число Х." Язык Pascal. Заранее благодарна.
Ответы (1)
Это цикл for: 1) даны натуральные числа X и Y. вычислить X*Y, пользуясь только оперцией сложения. 2) даны натуральные числа X и Y. вычислить X^Y 3) дано натуральное число N. найти сумму S=1+1/2+1/3 + ... + 1/N. 4) дано натуральное число N и число Х.
Ответы (1)
Из трехзначного числа Х вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа Х, то получилось число 237. Найти число Х
Ответы (2)
1. Из трехзначного числа x вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа x, то получилось число 237. Найти число x.
Ответы (1)
Из трехзначного числа x вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа x, то получилось 237. Найти число x. Решить на Паскале
Ответы (1)