Задать вопрос
10 ноября, 08:02

Составить программу, удваивающую буквы "а" и "б" в слове. pascal

+1
Ответы (1)
  1. 10 ноября, 11:20
    0
    var s:string;

    i:integer;

    begin

    write ('Введите строку: ') ;

    readln (s) ;

    for i:=length (s) downto 1 do

    begin

    if s[i]='а' then insert ('а', s, i) ;

    if s[i]='б' then insert ('б', s, i) ;

    if s[i]='А' then insert ('А', s, i) ;

    if s[i]='Б' then insert ('Б', s, i) ;

    end;

    writeln (s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу, удваивающую буквы "а" и "б" в слове. pascal ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы