Задать вопрос
23 февраля, 07:20

Составить программу.

Дано натуральное число n. Подсчитать количество цифр этого числа.

+5
Ответы (2)
  1. 23 февраля, 07:29
    0
    Program chisla;

    uses crt;

    var a, b, c: integer;

    begin

    writeln ('Введите натуральное число: ') ;

    readln (a) ;

    b:=a;

    c:=0;

    while b 0 do

    begin

    c:=c+1;

    b: = b div 10;

    end;

    writeln ('B числе ', a,' - ', c, ' цифр') ;

    end.
  2. 23 февраля, 08:26
    0
    Var

    n: longint;

    s: string;

    k: byte;

    begin

    Write ('Введите натуральное число ') ; Readln (n) ;

    { Преобразуем число к строке, убрав знак (мало ли ...) }

    Str (abs (n), s) ;

    { Выведем длину полученной строки }

    Writeln ('Количество цифр в числе равно ', Length (s))

    end.

    Тестовое решение:

    Введите натуральное число 164275353

    Количество цифр в числе равно 9
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу. Дано натуральное число n. Подсчитать количество цифр этого числа. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы