Задать вопрос
14 ноября, 07:34

Прошу Помогите я вам буду очень благодарен! Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256.

+4
Ответы (1)
  1. 14 ноября, 08:06
    0
    Program n1;

    var a, sum, k: integer;

    begin

    write ('введите число: ') ;

    readln (a) ;

    k:=1;

    sum:=0;

    while a0 do

    begin

    if (k=1000) or (abs (a) >30000) then break;

    if (a mod 2=0) and (a>0) and (a<256) then sum:=sum+a;

    k:=k+1;

    write ('введите число: ') ;

    readln (a) ;

    end;

    writeln ('количество: ', k) ;

    writeln ('сумма: ', sum) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Прошу Помогите я вам буду очень благодарен! Напишите программу, которая в последовательности целых чисел определяет их количество и ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы