Задать вопрос
20 сентября, 17:55

Написать программу с использованием цикла while. Через каждые пять секунд каждая амеба делиться на две амебы. Изначально была 1 амеба. Сколько амеб будет через N секунд? Проверить решение для 10, 25, 72 секунд.

+3
Ответы (1)
  1. 20 сентября, 18:34
    0
    Это просто! Вот решение:

    Var n, a, time:integer;

    Begin

    Readln (n) ;

    a:=1; time:=0;

    while time
    if frac (time/5) = 0 then a:=a*2;

    time:=time+1; / / èëè âìåñòî ýòîãî " Inc (time) ; "

    End;

    Writeln (a) ;

    End.

    И результаты проверки:

    10 секунд: 4 амёбы

    25 секунд: 32 амёбы

    72 секунды: 32768 амёбы
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу с использованием цикла while. Через каждые пять секунд каждая амеба делиться на две амебы. Изначально была 1 амеба. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы