Задать вопрос
4 января, 11:37

Даны три действительных числа. Если только два из них равны между собой, то возвести все числа в квадрат и напечатать в противном случае напечатать все три числа. Написать программу

+4
Ответы (1)
  1. 4 января, 15:20
    0
    Var

    a, b, c : real;

    begin

    read (a, b, c) ;

    if (a = b) xor (b = c) xor (a = c) then / / если только одно из равенств верно

    write (sqr (a), ' ', sqr (b), ' ', sqr (c))

    else write (a, ' ', b, ' ', c) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Даны три действительных числа. Если только два из них равны между собой, то возвести все числа в квадрат и напечатать в противном случае ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы