Задать вопрос
31 марта, 19:26

Даны натуральные числа n a1 ... an. составьте программу которая вычисляет сумму тех элементов последовательности а1 ... an которые кратны 3 м

+2
Ответы (1)
  1. 31 марта, 19:44
    0
    Const n=100;

    var a: array [1 ... n] of integer;

    s, i: integer;

    begin

    s:=0;

    for i:=1 to n do

    { вывод массива на экран }

    begin

    a[i]:=Random (100) ;

    write (a[i],' ') ;

    if (i mod 10 = 0) then writeln () ;

    end;

    { подсчет суммы элементов, кратных 3 }

    for i:=1 to n do

    if (a[i] mod 3 = 0) then s:=s+a[i];

    writeln ('сумма равна ', s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Даны натуральные числа n a1 ... an. составьте программу которая вычисляет сумму тех элементов последовательности а1 ... an которые кратны 3 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы