Задать вопрос
10 января, 13:47

Задача А Четные

N-Factorial - это произведение всех чисел от 1 до N. Для заданного числа N определите, сколько нулей в конце десятичной записи.

Формат входных данных

В единственной строке входного файла содержится одно целое положительно число N (1 N).

Формат выходных данных

Выведите одно целое число-количество нулей в конце десятичной записи N-Factorial.

Имя выходного файла: A. in

Имя выходного файла: А. out

Имя файла решения задачи: A.{c, cpp, pas}

Ограничение по времени: 2 секунды

Ограничение по памяти: 64 мегабайт.

Пример:

A. in A. out Комментарий

4 0 1*2*3*4=24

6 1 1*2*3*4*5*6=720

10 2 1*2*3*4*5*6*7*8*9*10=3628800

+2
Ответы (1)
  1. 10 января, 16:10
    0
    Uses crt;

    var n, mult, i, ans:integer;

    begin

    read (n) ;

    mult:=1;

    for i:=2 to n do

    mult:=mult*i;

    while mult mod 10=0 do begin

    inc (ans) ;

    mult:=mult div 10;

    end;

    writeln (ans) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача А Четные N-Factorial - это произведение всех чисел от 1 до N. Для заданного числа N определите, сколько нулей в конце десятичной ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы