Задать вопрос
5 марта, 00:45

Написать программу "Выделение цифр в записи числа" Дано трехзначное число. Определить, является ли сумма его цифр кратна 3 и 5.

+3
Ответы (1)
  1. 5 марта, 01:29
    0
    var

    a, s, n:integer;

    begin

    repeat

    write ('A = ') ; readln (a) ;

    until (a>=100) and (a<=999) ;

    n:=a;

    while n div 10 0 do begin

    n:=a;

    s:=s+a mod 10;

    a:=a div 10;

    end;

    if (s mod 3 = 0) or (s mod 5 = 0) then writeln ('Yes') else writeln ('No') ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу "Выделение цифр в записи числа" Дано трехзначное число. Определить, является ли сумма его цифр кратна 3 и 5. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы