Задать вопрос
16 мая, 10:40

Напишите программу, которая по данному числу n от 1 до 9 выводит на экран n флагов. Изображение одного флага имеет размер 4*4 символов, между двумя соседними флагами также имеется пустой (из пробелов) столбец. Разрешается вывести пустой столбец после последнего флага. Внутри каждого флага должен быть записан его номер - число от 1 до n.

входные данные

1

выходные данные

+___

|1 /

|__/

|

Паскаль. Нужно использовать фор.

+4
Ответы (1)
  1. 16 мая, 13:06
    0
    Var

    i, n:integer;

    begin

    read (n) ;

    for i:=1 to n do

    write ('+___ ') ;

    writeln;

    for i:=1 to n do

    write ('|', i,' / ') ;

    writeln;

    for i:=1 to n do

    write ('|__ / ') ;

    writeln;

    for i:=1 to n do

    write ('| ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая по данному числу n от 1 до 9 выводит на экран n флагов. Изображение одного флага имеет размер 4*4 символов, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы