Задать вопрос
26 апреля, 08:54

По данному натуральному значению n вычислите

1+1/3+1/5+1/7 + ... + 1/2n+1

на вход программе подаётся натуральное число n<100000

+5
Ответы (1)
  1. 26 апреля, 12:21
    0
    Var

    i, n:integer;

    s:real;

    begin

    Write ('n=') ; Read (n) ;

    s:=1;

    for i:=1 to n do s:=s+1 / (2*i+1) ;

    Writeln ('S=', s)

    end.

    Пример

    n=10

    S=2.1808745777786
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «По данному натуральному значению n вычислите 1+1/3+1/5+1/7 + ... + 1/2n+1 на вход программе подаётся натуральное число n ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы