Задать вопрос
4 марта, 02:51

Составьте программу, которая выводит все делители натурального числа N (в паскале)

+1
Ответы (1)
  1. 4 марта, 03:26
    0
    Var n, i:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    writeln ('Делители:') ;

    for i:=1 to n div 2 do

    if n mod i = 0 then write (i,' ') ;

    writeln (n) ;

    end.

    Пример:

    n = 24

    Делители:

    1 2 3 4 6 8 12 24
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу, которая выводит все делители натурального числа N (в паскале) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы