Задать вопрос
12 октября, 05:35

Написать программу (в Pascal), которая определяет полную поверхность 30-ти шаров. Радиус первого составляет 59 м, а каждого последующего уменьшается на 1 м.

+1
Ответы (1)
  1. 12 октября, 06:33
    0
    Блок-схема - в прилагаемом файле.

    var r:integer; s:real;

    begin

    s:=0;

    for r:=59 downto 30 do

    s:=s+4*pi*r*r;

    writeln ('s = ', s:10:3) ;

    end.

    Результат:

    s = 774779.580
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу (в Pascal), которая определяет полную поверхность 30-ти шаров. Радиус первого составляет 59 м, а каждого последующего ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы