Задать вопрос
8 мая, 15:06

Напишите рекурсивную функцию подсчёта количества цифр в натуральном числе.

Формат входных данных

На вход ваша программа получает одно натуральное число n (1≤n≤216-11≤n≤216-1).

Формат выходных данных

Выведите одно число - количество цифр в числе n.

+4
Ответы (2)
  1. 8 мая, 16:50
    0
    Var n:longint;

    function kol (n:integer) : integer;

    begin

    if n<10

    then kol:=1

    else kol:=kol (n div 10) + 1;

    end;

    begin

    write ('n = ') ;

    readln (n) ;

    writeln ('k = ', kol (n)) ;

    end.

    Пример:

    n = 15324

    k = 5
  2. 8 мая, 17:16
    0
    Var n: integer;

    function f (n: integer) : integer;

    begin

    if (n < 10) then f : = 1

    else f : = f (n div 10) + 1;

    end;

    begin

    readln (n) ;

    write (f (n)) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите рекурсивную функцию подсчёта количества цифр в натуральном числе. Формат входных данных На вход ваша программа получает одно ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы