Задать вопрос
24 сентября, 23:00

Паскаль

Формат входных данных Сначала задано число N - количество элементов в массиве (1N35). Далее через пробел записаны N чисел - элементы массива.

Формат выходных данных

Необходимо вывести значение наибольшего элемента в массиве.

+5
Ответы (1)
  1. 25 сентября, 00:50
    0
    Program gtr;

    var a:array[1 ... 1000]of integer;

    n, i, max:integer;

    begin

    read (n) ;

    for i:=1 to n do

    read (a[i]) ;

    max:=a[1];

    for i:=2 to n do

    if (a[i]>max) then max:=a[i];

    writeln (max) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Паскаль Формат входных данных Сначала задано число N - количество элементов в массиве (1N35). Далее через пробел записаны N чисел - ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данных Сначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
Вводится массив, состоящий из целых чисел. Найти наибольшее среди них. Входные данные Сначала задано число N - количество элементов в массиве (1N35). Далее через пробел записаны N чисел - элементы массива. Массив состоит из целых чисел.
Ответы (1)
Дан массив a из n целых чисел. Требуется сначала вывести элементы, стоящие на четных местах, затем - на нечетных. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив a из n целых чисел. Требуется сначала вывести все четные элементы, затем - нечетные. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Сначала задано число N - количество элементов в массиве. Далее через пробел записаны N чисел - элементы массива. Необходимо вывести все четные элементы массива (то есть те элементы, которые являются четными числами).
Ответы (1)