Задать вопрос
11 ноября, 19:47

Решите задачу с циклами While и if: Определите количество четных элементов в последовательности, завершающейся числом 0.

+2
Ответы (1)
  1. 11 ноября, 20:54
    0
    Как я понял, нужно определить четные элементы массива.

    Var a:array[1 ... 6] of integer;

    x, n:integer;

    begin

    For x:=1 to 6 do

    read (a[x]) ;

    n:=0;

    For x:=1 to 6 do

    If a[x] mod 2=0 then n:=n=1;

    Writeln (n) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Решите задачу с циклами While и if: Определите количество четных элементов в последовательности, завершающейся числом 0. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы