Задать вопрос
8 апреля, 23:27

На паскале нужно решить задачи

1. Задано трехзначное число. Составьте программу, с помощью которой определите произведение кубов цифр этого числа.

2. Задано трехзначное число. Составьте программу, с помощью которой определите, равняются ли в нем крайние числа.

+5
Ответы (1)
  1. 9 апреля, 01:54
    0
    var

    a, e, d, s, p: integer;

    begin

    p:=1;

    writeln ('введи трехзначное число') ;

    read (a) ;

    e: = (a mod 10) ;

    s: = (a div 100) ;

    d:=s*100-e;

    p:=s*s*s*d*d*d*e*e*e;

    writeln ('произведение кубов цифр числа равно', p) ;

    if e=s then writeln ('первая цифра числа равна последней')

    else

    writeln ('первая цифра числа не равна последней') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «На паскале нужно решить задачи 1. Задано трехзначное число. Составьте программу, с помощью которой определите произведение кубов цифр этого ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы