Задать вопрос
20 июля, 23:38

Сформируйте одномерный массив из n-элементов (значения элементов зависит от порядкового номера массива и вычисляется по формуле (i+5) ^2). Параметр n должен задавать пользователь. Напишите программу, вычисляющую сумму значений элементов одномерного массива и среднее арифметическое введенных n чисел. Вывод оформите в строку через пробел.

+2
Ответы (2)
  1. 21 июля, 00:11
    0
    Var

    a: array[1 ... 100] of integer;

    i, s, n: integer;

    begin

    readln (n) ;

    for i : = 1 to n do begin

    a[i] : = (i + 5) * (i + 5) ;

    write (a[i],' ') ;

    s : = s + a[i];

    end;

    writeln;

    writeln (s, ' ', s / n) ;

    end.
  2. 21 июля, 01:56
    0
    Uses crt;

    const m=1000;

    var a:array[1 ... m] of integer;

    i, s, n:integer;

    sr:real;

    begin

    readln (n) ;

    writeln;

    s:=0;

    for i:=1 to n do

    begin

    a[i]: = (i+5) * (i+5) ;

    writeln (a[i]) ;

    s:=s+a[i];

    end;

    writeln;

    sr:=s/n;

    writeln (s,' ', sr) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Сформируйте одномерный массив из n-элементов (значения элементов зависит от порядкового номера массива и вычисляется по формуле (i+5) ^2). ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы