Задать вопрос
14 апреля, 01:08

Написать программу на языке Pascal. Найти значение выражения для

заданного x.

1.1. 2x+5;

1.2. 3x^2+1x+7;

1.3. 3x+7;

1.4. 2x^2+7+10

Знак ^ обозначает степень числа, а в паскале записывается как Sqr (x), где x переменная.

+4
Ответы (2)
  1. 14 апреля, 02:33
    0
    Var x:integer;

    begin

    x: =; / / Сюда ввести значение.

    writeln (2*x+5) ;

    writeln (3*Sqr (x) + 1*x+7) ;

    writeln (3*x+7) ;

    writeln (2*sqr (x) + 7+10) ;

    end.

    С вводом X:

    var x:integer;

    begin

    writeln ('Введите x: ') ;

    readln (x) ;

    writeln (2*x+5) ;

    writeln (3*Sqr (x) + 1*x+7) ;

    writeln (3*x+7) ;

    writeln (2*sqr (x) + 7+10) ;

    end.
  2. 14 апреля, 03:06
    0
    Var

    x, i, a1, a2, a3, a4:integer;

    Begin

    readln (x) ;

    a1:=2*x+5;

    a2:=3*sqr (x) + x+7;

    a3:=3*x+7;

    a4:=2*sqr (x) + 7+10;

    writeln (a1) ;

    writeln (a2) ;

    writeln (a3) ;

    writeln (a4) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу на языке Pascal. Найти значение выражения для заданного x. 1.1. 2x+5; 1.2. 3x^2+1x+7; 1.3. 3x+7; 1.4. 2x^2+7+10 Знак ^ ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы