Задать вопрос
1 августа, 12:47

Написать программу, которая позволяет просматривать текстовые файлы (выводит на экран содержимое файла), например, файлы исходных программ Turbo Pascal. Имя просматриваемого файла должно вводится во время работы программы. Рекомендуемый вид экрана приведен ниже. Просмотр текстового файла. Введите полное имя файла и нажмите. - > d:/tp/pas/numb. pas

+1
Ответы (1)
  1. 1 августа, 16:22
    0
    Var f1:text;

    st:string;

    begin

    write ('введите имя файла ') ;

    readln (f1) ;

    reset (f1) ; { открыть файл для чтения }

    while not eof (f1) do { пока не конец файла f1}

    begin

    readln (f1, st) ; {читаем строку из файла f1 }

    writeln (st) ; { выводим на экран }

    end;

    close (f1) ; { закрыть файл для чтения}

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая позволяет просматривать текстовые файлы (выводит на экран содержимое файла), например, файлы исходных программ ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы