Задать вопрос
11 июля, 04:20

Напишите программу, которая на вход получает целое число и проверяет, есть ли в числе 2 одинаковые цифры (pascal, с использованием циклов)

+1
Ответы (1)
  1. 11 июля, 04:42
    0
    Var a: array[0 ... 9] of integer;

    i, n, k: integer;

    pr: string;

    begin

    pr:='нет';

    for i:=0 to 9 do a[i]:=0;

    write ('число: ') ; readln (n) ;

    repeat

    k:=n mod 10;

    a[k]:=a[k]+1;

    if a[k]>1 then

    begin

    pr:='есть';

    break;

    end;

    n:=n div 10;

    until n=0;

    writeln (pr) ;

    end.

    ввод - вывод

    число: 122456

    есть

    число: 12546

    нет
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая на вход получает целое число и проверяет, есть ли в числе 2 одинаковые цифры (pascal, с использованием циклов) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы