Задать вопрос
13 февраля, 14:16

Составить программу на паскале. Даны стороны двух треугольников. Найти сумму их периметров и сумму площадей. Определить процедуру для расчета периметра и площади треугольника по его сторонам

+3
Ответы (1)
  1. 13 февраля, 16:39
    0
    Var z, x, c:real;

    procedure Perimetr (a, b, c:real) ;

    var p:real;

    begin

    p:=a+b+c;

    writeln ('P=', p) ;

    end;

    procedure Ploshad (a, b, c:real) ;

    var s, p:real;

    begin

    p: = (a+b+c) / 2;

    s:=sqrt (p * (p-a) * (p-b) * (p-c)) ;

    writeln ('S=', s) ;

    end;

    begin

    writeln ('Write first dа ta:') ;

    readln (z, x, c) ;

    Perimetr (z, x, c) ;

    Ploshad (z, x, c) ;

    writeln ('Write second dа ta:') ;

    readln (z, x, c) ;

    Perimetr (z, x, c) ;

    Ploshad (z, x, c) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу на паскале. Даны стороны двух треугольников. Найти сумму их периметров и сумму площадей. Определить процедуру для ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы