Задать вопрос
27 мая, 16:48

Сделать в Free Pascal.

В салон красоты пришло n девушек. Каждая из них должна посетить парикмахера и косметолога. У каждого она проводит по m часов. За какое наименьшее время k сотрудников салона красоты смогут обслужить всех девушек, если каждый сотрудник может выполнять функции как косметолога, так и парикмахера?

Входные данные

три натуральных числа k, m, n (все числа не больше 10 000).

Исходные данные

одно число - минимальное время в часах, которое требуется для обслуживания всех девушек.

+1
Ответы (1)
  1. 27 мая, 19:49
    0
    Begin

    write ('n m k через пробел: ') ;

    readln (n, m, k) ;

    s:=2*n*m;

    p:=0;

    repeat

    s:=s-k*2*m;

    p:=p+1;

    until s<=0;

    p:=p*2*m;

    writeln ('время: ', p) ;

    end.

    n m k через пробел: 3 2 5

    время: 4

    n m k через пробел: 6 2 4

    время: 8
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Сделать в Free Pascal. В салон красоты пришло n девушек. Каждая из них должна посетить парикмахера и косметолога. У каждого она проводит по ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы