Задать вопрос
19 мая, 17:21

Винни-Пуху прислали посылку - K литров мёда. Сначала он попытался разлить его в бочонки по 2 литра, но вот незадача - 1 литр остался. Потом попытался разлить в бочонки по 3 литра, и опять осталось 2 литра. И так далее, пока он не разлил мёд в бочонки по N литров, и у него осталось N-1 литров мёда. Определите, какое минимальное количество мёда могли прислать Винни.

Формат входных данных:

Строка, содержащая целое число N (2≤N≤19).

Формат выходных данных:

Вывести требуемое число K.

+1
Ответы (1)
  1. 19 мая, 17:29
    0
    Var n, k, i:integer; f:boolean;

    begin

    readln (n) ;

    k:=1;

    f:=false;

    while not f do

    begin

    k:=k+1;

    f:=true;

    for i:=2 to n do

    f:=f and (k mod i=i-1) ;

    end;

    writeln (k) ;

    end.

    Пример (для 19 долго считает, можно оптимизировать, если нужно) :

    19

    232792559
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Винни-Пуху прислали посылку - K литров мёда. Сначала он попытался разлить его в бочонки по 2 литра, но вот незадача - 1 литр остался. Потом ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы