Задать вопрос
31 января, 01:44

Задача по программированию на Паскаль, нужна помощь.

Дана строка состоящая из строчных букв английского алфавита. Необходимо определить какие буквы встречаются в этой строке больше одного раза.

Формат входных файлов: Входной файл содержит одну строку S длиной не более чем 100 символов, состоящую из букв a, b, c ...

Выходной файл должен содержать в алфавитном порядке последовательность букв строки S, которые встречаются в ней больше одного раза. Каждая буква выводится не больше одного раза.

+2
Ответы (1)
  1. 31 января, 02:50
    0
    Var t1, t2:text;

    s:string;

    k:array['a' ... 'z']of integer;

    i:integer; c:char;

    begin

    assign (t1,'input. txt') ;

    reset (t1) ;

    assign (t2,'output. txt') ;

    rewrite (t2) ;

    readln (t1, s) ;

    for c:='a' to 'z' do k[c]:=0;

    for i:=1 to length (s) do k[s[i]]:=k[s[i]]+1;

    for c:='a' to 'z' do

    if k[c]>1 then write (t2, c) ;

    writeln (t2) ;

    close (t1) ; close (t2) ;

    end.

    Пример:

    Файл input. txt:

    xyzabcdefgabcdx

    Файл output. txt

    abcdx
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача по программированию на Паскаль, нужна помощь. Дана строка состоящая из строчных букв английского алфавита. Необходимо определить ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы